Nip DATA Logo  
 

Contents



ByteDesigner icon Byte Designer

Professional database modeling


Chapter 6

Workspace

About this chapter

This chapter describes and explains the Workspace.

What Is It

The Workspace contains all of the objects needed to perform a modeling task. One, and only one, Workspace is always in use while working with Byte Designer and it is represented as the top object in the browser. The Workspace is a type of container which is saved as an XML file - child objects are not stored in the Workspace file but, instead, references to any child objects. The file extension is ".DAWorkspace".

Using The Workspace

The purpose of the Workspace is to group objects you are working on such that your work session can be quickly restored. When the Byte Designer application is executed the browser will contain one object - a Workspace (workspace). All objects are added inside (or below) the Workspace. Once a work session is complete the Workspace is saved (if desired) and the application can be closed. Later, the Workspace can be loaded using the recent file list in the File menu or using the File->Open Workspace menu option. The browser will show the objects in the Workspace allowing work to quickly resume.

Menu Options

The Workspace has its own popup menu which can be accessed by <right-clicking> on it in the browser. Some menu options on the main menu will also perform their task on the Workspace; File->Open Workspace, and File->Save Workspace for example.

tip
File->Open will, by default, add the loaded object as a child of the Workspace.

Editing Properties

The Workspace property dialog is invoked by selecting the Properties menu option (prop) from the Workspace popup menu. The Workspace has only the most basic properties; Name, Code, Comment.

Adding Child Objects

Child objects can be added to the Workspace by using the Workspace popup menu in the browser or by using the File menu options on the main window. The Workspace popup menu has the following relevant options; New, Open and Add. In all cases a reference is added to the Workspace. The Add option differs from the Open in that it allows multiple files to be selected and does not try to load any of them.

The following table shows the object types which can be added as a child of a Workspace;

Icon
Name
project
Project
diagram
Diagram (free-form)
lm Logical Model
pm
Physical Model
sql file
SQL File


caution
The Workspace references are relative file names. The fact that the reference uses relative, instead of absolute file names allows the Workspace file to be used on another machine. However; moving the Workspace files or any of the files it references may result in the reference becoming invalid.

Removing Child Objects

Objects which are immediate children of the Workspace can be removed by invoking the popup menu of the object to be removed and selecting the Remove (del) option. This does not delete any files on the disk - it simply removes the reference from the Workspace.