run ByteDesigner on RHEL 6.1

Linux administration questions.

run ByteDesigner on RHEL 6.1

Postby marian » Mon Dec 13, 2010 1:26 pm

We received the following error, when ByteDesigner is used on Rh 6.1:

> Hi I've moved to a new computer running RHEL 6.1
>
> I installed the following:
>
> unixODBC-devel-2.2.14-11.el6.i686
> unixODBC-2.2.14-11.el6.i686
> unixODBC-kde-2.2.14-11.el6.i686
> nipdata-support-1.6-100614.i386
> ByteDesigner -2.1-100614.i386
>
> However when I try and start ByteDesigner I get this:
>
> unixODBC libraries are not installed/configured on this system !
> See http://www.unixodbc.com
>
>
> Even though I do have the unixODBC libraries installed
> (unixODBC-devel-2.2.14-11.el6.i686)
>
>
> Thoughts?
marian
Site Admin
 
Posts: 16
Joined: Tue Jul 14, 2009 9:13 am

Invitations sent: 15
Successful invitations: 2

Re: run DataArchitect on RHEL 6.1

Postby marian » Mon Dec 13, 2010 1:33 pm

First, we need to ensure that unixODBC libs are seen. You need to make
them visible, using /etc/etc/ld.so.conf (followed by ldconfig) or LD_LIBRARY_PATH,
if unixODBC libs are installed in a non default path.

Once that is done, and the error is still seen, make sure the following links are
created:
# cd /usr/lib/
# ln -s libodbc.so.2 libodbc.so.1
# ln -s libodbcinst.so.2 libodbcinst.so.1

We assumed here, that unixODBC libs are installed in the /usr/lib/ default path.

RH 6.1 uses version 2 for the unixODBC lib names, while ByteDesigner expects version 1 in the name.
Simply creating the above links, fixes the problem.
marian
Site Admin
 
Posts: 16
Joined: Tue Jul 14, 2009 9:13 am

Invitations sent: 15
Successful invitations: 2


Return to Linux Administration

Who is online

Users browsing this forum: No registered users and 1 guest

cron